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Convert your Windows Server 2003 to a Workstation - http://www.msfn.org/win2k3/misc.htm

Updates:
5th August - New XP Games Installer, does not need a Windows XP disc! 
20th July - New TweakUI 2.10 for Windows XP & Windows Server 2003. See Tweaks Section for download.
15th July - System Restore implemented into the Step by Step Guide! At last!


Pre-Setup
I'm sure you'll know how to install Windows Server 2003, its basically done the same way as Windows XP. Assuming you want to run it as a workstation then leave the CAL (Client Access License) settings as they are when you come across it during Setup. Let's move on!


Post-Setup
	The first thing you should do is disable the Manage Your Server window, you don't want it nagging you everytime you boot up Windows do you? Simply tick the box "Don't display this page at logon". You can access it later via Control Panel -> Administrative Tools -> Manage Your Server.
	



Creating a New User Account

The Welcome Screen is non-existant in Windows Server 2003, so you weren't prompted to make a new user name upon first boot-up. But worry not, its fairly simple to do, as everything in this guide is! I would like to thank Donald Morris for this new submission, replacing the advanced lusrmgr.msc (Local Users and Groups) completely.

	



	Go to Start -> Run -> and type in rundll32 netplwiz.dll,UsersRunDll and press enter. The User Accounts window will appear. Click on Add and then fill in the necessary fields with your User name, Full name, and Description. Click on Next and fill in both password fields as shown here and then click on Next. On the next wizard box as shown here, choose Other and select Administrators, lastly click on Finish! 
If you wish for a more advanced configuration, you can always use lusrmgr.msc by running it from the Run box again.

Incase you're wondering, rundll32 netplwiz.dll,UsersRunDll is the same as control userpasswords2


	Now that we've set up a personal user account, we want it to autologon without the use of TweakUI. If you don't wish for this feature please skip this step.

Make sure your name is highlighted in the User Accounts window, as shown in the screenshot to the right, and then uncheck the box Users must enter a user name and password to use this computer and then click on Apply. If you did it right, you will get another window asking for the password to use for autologon on your account name as shown in this screenshot here. Fill in both password fields, and you're ready to go!

Now log off and log in with your new account!
	





Disabling the CTRL+ALT+DEL Prompt
You've managed to avoid the annoying CTRL+ALT+DEL prompt by using autologon... but it's still there! The CTRL+ALT+DEL prompt will still show up when you lock your PC (Winkey +L) or when you use a password protected screensaver. In here, we'll show you how to disable it completely.

	


	Go to Control Panel -> Administrative Tools -> Local Security Policy. Browse to Local Policies -> Security Options.

On the right windows pane, scroll down until you find Interactive logon: Do not require CTRL+ALT+DEL, double click and then select Enabled (as shown in the screenshot)


Disabling Internet Explorer Enhanced Security

A new security feature of Windows Server 2003 has set Internet Explorer to high security by default, so you won't be able to browse any sites. Want to fix this? Read on!

	


	To remove Internet Explorer's Enhanced Security Configuration, we will need to do this via Add or Remove Programs. Go to Control Panel -> Add or Remove Programs -> Add/Remove Windows Components -> and then scroll down until you see Internet Explorer Enhanced Security Configuration. Click on Details and uncheck both boxes as shown in the screenshot to the left. Click OK and OK!


	Now fire up Internet Explorer and you'll be faced with the page as shown in the screenshot to the right, warning you that IE's Enhanced Security Configuration is not enabled. Simply change your homepage in Internet Explorer's options, and that's it, you won't be seeing it again!
	




Installing Sun Java VM

Windows Server 2003 ships without Microsoft Java VM, and Microsoft no longer hosts the necessary Java VM files. There are plenty of other places where you can obtain the MS Java VM, but I have not chosen to install it because:

1. It will no longer be updated to patch any forthcoming security exploits. 

2. Many of the various download locations for MS Java VM differ in size, how would you know exactly which one to get? 

Grab a copy of Sun's Java VM from Sun's download page: http://java.sun.com/getjava/manual.html. 

The installation process is easy, and it won't require a reboot either. Now lets move on to disabling the Shutdown Event Tracker, allowing us to reboot without the bloody nuisance of an event tracker window!

Disabling the Shutdown Event Tracker

Because Windows Server 2003 is a 'Server', the event tracker plays a crucial role so that it can keep logs on why the server was shutdown/rebooted. Since we want it to be a Workstation, we will easily attempt to disable this feature. Again, its so damn simple :-)

	


	We will need to go into Group Policy Object Editor, go to Start -> Run -> and type gpedit.msc followed by enter. 
You should see the Group Policy Editor as shown on the left. 
Browse to Computer Configuration 
-> Administrative Templates
 -> System 
-> now look in the right window pane and double click on Display Shutdown Event Tracker.


	This window will now appear, simply select Disabled and then proceed to click on OK. 
Now close the Group Policy Object Editor window. 
If all goes well, you should get this when you attempt to shutdown:
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Enabling Hardware and DirectX Acceleration

Graphics Hardware Acceleration and DirectX are disabled by default on a Server configuration to ensure maximum stability and uptime. But for any reason you need to enable them to use DirectX enabled applications this section will guide you through on how you can do it.

Enabling Graphics Hardware Acceleration
	


	Let's start with enabling the Hardware acceleration on our graphics card. Simply right click anywhere on your desktop and select Properties -> Settings tab -> Advanced -> and finally, the Troubleshoot tab.

Now move the Hardware acceleration slider across to Full
Click OK
You may experience a monitor black out for a few seconds, this is normal.



Enabling DirectX
	We now want to enable the full capabilities of DirectX. To do this, go to Start -> Run -> and type dxdiag followed by enter. You will get a dialog box asking if you want to allow dxdiag to access the internet to check for valid WHQL certificates - click on Yes. 

Let's click on the Display tab, now click on all three boxes to enable DirectDraw, Direct3D and AGP Texture Acceleration.
	




Enabling Sound Acceleration

Now that we've enabled acceleration for our Graphics card and DirectX, we want to enable the audio, read on!

	If you are using Windows Server 2003 Standard Edition, move on to the next step as the Windows Audio Service is already enabled. For other editions, read on.

Go to Start -> Run -> and type Services.msc followed by enter. 
The Services window will appear, scroll down until you find "Windows Audio". 
Double click on Windows Audio -> and change the startup type to Automatic -> then Apply -> Start -> OK
 
	



	


	Lastly, we will need to go back into DirectX Diagnostics. 
Click on Start -> Run -> and type dxdiag followed by enter. 
This time, go to the Sound tab and move the slider on "Hardware Sound Acceleration Level" to Full Acceleration.


Great! We have sound enabled, now go and grab a copy of Winamp and play some music to soothe yourself! :-)

Not forgetting, if you have a SB Live! card like I do, you should grab the LiveDrvUni-Pack for Win2K/XP dated 10th March 2003. There is absolutely no need to extract and install the drivers manually, because the setup program works just fine on Windows Server 2003!

Enabling Themes and patching UXTheme.dll

Where are the themes I hear you scream! You've come to the right place. Let's get them enabled with little effort!

	We will need to go back into Services to enable the Themes Services. Go to Start -> Run -> and type Services.msc followed by enter. Scroll down until you find "Themes", now double click on Themes -> change the startup type to Automatic -> Apply -> Start -> OK. Now close the Services window.

For now you only have Luna Blue, Silver and Olive Green to choose from.

Want to use a hacked visual style? Move on to the next step to easily patch your UXTheme.dll
	




Manual Installation
Thanks goes out to Vortex.Winbeta.org for supplying us with a patched UXTheme.dll. There were no instructions included, so I've added a batchfile (*.cmd) thanks to Fredrik Thorson. If you'd rather use an autopatcher, click here otherwise proceed with the instructions outlined below:

Download: UXThemePatch.zip 

(if for any reason you need to restore your original uxtheme.dll - Click here to download)

Extract the zipped file and follow these steps:

1. Copy UXTheme.dll to C:\WINDOWS\System32\dllcache 

2. Copy the uxthemepatch.cmd to the root of your C:\ drive 

3. Reboot into Safe Mode Command Prompt (Press F8 upon booting) 

4. Once the Command Prompt has loaded, type cd\ followed by enter, then type uxthemepatch followed by enter. 

That's it! Remember to replace C:\WINDOWS with your drive and WINDOWS folder name where applicable!

Automatic Installation 

Courtesy of xBetas and Tech-Critic, we have 2 different AutoPatchers to simplify the process of patching your UXTheme.dll, let's download either one from the links below. The screenshots used in this demonstration is the xBetas patch.

Download: xBetas' PatchXP | UXTheme Multi-Patcher for XP/2003
	As the patcher says, just click the Patch button, ignore any Microsoft or WFP related messages (I didn't get any though) and then click on Reboot!

	

 


If you followed the instructions well, you should now be able to use hacked visual styles on Windows Server 2003!


Many people have requested by email what theme I'm using in the above screenshot. It's called Watercolor XP v4.2 and can be downloaded at Themexp.org by using the search engine (search for Watercolor)

If you want to theme your Startup and Shutdown windows, please go to Themes Xtra
Enabling Other Services

In this section we will show you how to:

1. Enable the inbuilt IMAPI CD-Burning Service 

2. Enable Windows Image Acquisition (for Webcams, Scanners etc) 

If you do not wish to enable any of these services, please move on to the next section - Advanced Configuration.

	If you wish to use the inbuilt CD-Burning Service, follow these instructions: (Its recommended you leave this disabled if you want to speed up the Nero Burning ROM startup)

Go to Start -> Run -> and type in Services.msc and scroll down until you find the "IMAPI CD-Burning COM Service", double click on IMAPI CD-Burning COM Service and select startup type Automatic -> Apply -> Start -> OK.

Reboot to enable the CD Burning item in "Send-To".
	




	


	If you have a Camera, Webcam or Scanner, follow these instructions:

Go to Start -> Run -> and type in Services.msc and scroll down until you find the "Windows Image Acquisition (WIA) ", double click on Windows Image Acquisition (WIA) and select startup type Automatic -> Apply -> Start -> OK.

 


Now install the drivers for your Camera, Webcam, or Scanner!

Advanced Configuration

In this section, we will go deep into the core of Windows Server 2003, where the memory and processor usage is handled. We will want to change some settings as it isn't currently optimized for Workstation usage.

	Let's go into Performance Options and change the performance settings for processor and memory resources. Here's how to get there:

Go to Control Panel -> System -> Advanced -> Performance Settings -> Advanced tab. Change Processor scheduling to Programs and lastly, change Memory usage to Programs. Now click on OK.

 
	




	


	If you're still at the System Properties Window, you might want to disable Error Reporting. Click on Error Reporting -> and then choose Disable Error Reporting -> and tick But, notify me when critical errors occur.


Installing DirectX 9.0a

The installation process of DirectX 9.0a is just the same as any other DirectX installation on any of the previous Windows versions. If you haven't yet enabled DirectX and Graphics Acceleration then please do so now before proceeding!

To start off, grab a copy of DirectX 9.0a Websetup or the Redistributable from the link below:

Download: DirectX 9.0a Websetup | DirectX 9.0a Redistributable (for all Windows)

Execute the setup file and go through the setup process, it will download approx. 6.9 MB of files. If you downloaded the Redistributable, it will not need to download any components as this is already included in the package.

	


	




That's it, now go and reboot!

How to enable System Restore

The most requested feature (apart from the Logon Screen & Fast User Switching) is here! You will need your Windows XP CD on hand to install this, as files from Windows XP are required to install System Restore into Windows Server 2003. 

Please take care when using System Restore, as system instabilities are still unknown at this point, although it has been tried and tested! If your copy of Windows Server 2003 is to be used as a 100% workstation, then it should be OK to use System Restore!

The installation of System Restore is as easy as pie, follow the instructions below:

Download: Add System Restore
1. Extract the zip file into a folder, you will see two main files - AddSystemRestoreEntries.reg and sr.inf
2. Double click on AddSystemRestoreEntries.reg and click on Yes when prompted.

3. Insert your Windows XP CD

4. Right click on sr.inf and select Install.

5. Point to the /i386 directory on the CD if prompted. 

6. Reboot!

That simple eh! Many thanks to Gosh for this excellent hack!

Screenshots: Main System Restore Screen | System Restore tab in My Computer Properties 

Miscellaneous

Folder Options
	By default, all hidden files and folders are shown, you may want to hide this to reduce the number of files shown in Windows Explorer. 

It's clutter to me, is it to you? Hide them! Open any folder and go to Tools -> Folder Options -> View tab -> select Do not show hidden files and folders -> and lastly OK.
	




Windows Media Player 9
Windows Media Player 9 is already installed. To activate it, go to Start -> Programs -> Accessories -> Entertainment -> Windows Media Player. Now tick all the relevant checkboxes suited to your needs and you're ready to go!

You can also add Media Player 9 to your taskbar by: Right clicking on your Taskbar -> Toolbars -> Windows Media Player.

Working Antivirus applications
AVG Pro 
Eset NOD32
eTrust AntiVirus 7
F-Secure Anti-Virus for Servers 5.41
PC-Cillin 2003 (Grab the patched PCC.msi and refer to this readme.txt for instructions)
PC-Cillin 2002 (Grab the patched PCC.msi and refer to this readme.txt for instructions) 
Sophos Antivirus
Symantec Norton Antivirus Corporate 7.6
Symantec Norton Antivirus Corporate 8.x (Not Home versions of Norton Antivirus 2002/2003)

Working Firewalls
Norton Personal Firewall 2003
Sygate Personal Firewall v5.0 Build 1175
Tiny Personal Firewall 4.0 
ZoneAlarm v3.7.159 

I will update the Antivirus and Firewalls list when I get more information on them (it would be more helpful if you emailed me of any working Antivirus and Firewall applications for Windows Server 2003!) Please note that the above applications are based on user feedback so I haven't tested or verified any of them. 



That's it! You have successfully configured your Server to act as a Workstation, now you can resume all your usual day-to-day computer activities on Windows Server 2003! :-) You can find more info & extras such as TweakNT, XP Games, Tweaks, and Downloads from the navigation bar at the top. 
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